Ford Mustang | Mustangs  
Black Menu Tabs
Go Back   Mustangs Insanity > Mustang Talk > Mustangs > 4 Cylinder NA and Turbo
Home Register Members List Social Groups Mark Forums Read History Pictures/Videos Vendors Ford News

4 Cylinder NA and Turbo Discussions about stock or modified 4 cylinders, including the performance 2.3L mustangs

Reply
 
Bookmark and Share LinkBack Thread Tools Display Modes
Old 08-24-2009   #1 (permalink)
130Stang
Real Name: Mike
 
Loadclr's Avatar
 
Join Date: Mar 2007
Location:
Wichita, KS
Posts: 6,236
iTrader: (1)
Friends: (14)
 

Last Online:
02-17-2014 05:31 PM
Time Spent Online: 3 Weeks 1 Day 3 Hours 56 Minutes 35 Seconds
My Album's:
Loadclr's album
My Garage:
Loadclr's Garage

Thanks: 3
Thanked 13 Times in 13 Posts
Send a message via AIM to Loadclr Send a message via Yahoo to Loadclr
Sputter

My son is having an problem with his 4 banger Mustang. It seems that it occasionally sputters and loses power, but not much and not for long. He can't always replicate the problem. He says it only happens at high RPM and round 35 mph and again at 65 mph. We just replaced the fuel filter the other day. I'm sure all the vacuum lines are good. My son did (against my wishes) cut off the muffler and tailpipe so it is running straight pipe. I think it might be a piece of junk floating around the fuel system. Any suggestions?
__________________
My name is Mike and I have a Mustang addiction.

Body of an old man; Heart of a teenager

Life's journey is not to arrive at the grave safely in a well preserved body, but rather to skid in sideways, totally worn out, shouting"..........holy shit.......what a ride!"

I live with Fear everyday, but sometimes she lets me race............Fear Nothing

Improvise, adapt, overcome

Live in the country whose flag you want to fly!

Loadclr is offline Submit to Clesto

Submit to Digg Submit to Reddit Submit to Furl Submit to Del.icio.us Submit to Jeqq Submit to Spurl  
Reply With Quote
Old 08-25-2009   #2 (permalink)
Car Enthusiast
Real Name: Doug
 
hotwheels's Avatar
 
Join Date: Aug 2006
Location:
Cheyenne, Wyoming
Posts: 21,597
Twitter ID:
insanemustangs
iTrader: (0)
Friends: (418)
 

Last Online:
12-09-2021 11:49 PM
Time Spent Online: 4 Weeks 12 Hours 1 Minute 31 Seconds
My Album's:
hotwheels's album

Thanks: 4
Thanked 32 Times in 31 Posts
Re: Sputter

It's gonna be fuel or spark.......if you are sure the fuel pump is working, then check the wires, plugs, cap, etc...
__________________
Webmaster in training and owner of a mini Jay Leno Poorman's car collection

hotwheels is offline Submit to Clesto

Submit to Digg Submit to Reddit Submit to Furl Submit to Del.icio.us Submit to Jeqq Submit to Spurl  
Reply With Quote
Old 08-25-2009   #3 (permalink)
Leader of Men
Real Name: Brian
 
Intmdtr's Avatar
 
Join Date: May 2007
Location:
Wasaga Beach, Ontario
Posts: 9,551
iTrader: (1)
Friends: (34)
 

Last Online:
11-17-2021 08:31 PM
Time Spent Online: 2 Weeks 5 Days 22 Hours 36 Minutes 37 Seconds
My Album's:
Intmdtr's album
My Garage:
Intmdtr's Garage

Thanks: 0
Thanked 28 Times in 27 Posts
Send a message via MSN to Intmdtr
Re: Sputter

i have tested these things in the past by placing the car in third while driving around and at a higher RPM and listen for it to start breaking up or missing, around 4500rpms should do the trick. if it sputters there then plugs and wires and such is your prob.
__________________
HELLO My Name is BRIAN

"Without Warning, Without Conscience"



"Live life to the fullest, it's not a dress rehearsal"
Intmdtr is offline Submit to Clesto

Submit to Digg Submit to Reddit Submit to Furl Submit to Del.icio.us Submit to Jeqq Submit to Spurl  
Reply With Quote
Old 08-25-2009   #4 (permalink)
Junior Member
Real Name: Jason
 
91stang308's Avatar
 
Join Date: Apr 2007
Location:
Montpelier, Ohio
Posts: 2,984
iTrader: (1)
Friends: (16)
 
Last Online:
3 Weeks Ago 12:57 PM
Time Spent Online: 1 Week 3 Days 16 Hours 37 Minutes 41 Seconds
My Album's:
91stang308's album

Thanks: 0
Thanked 9 Times in 9 Posts
Re: Sputter

this doesnt have to do with the problem but i bet that lil 4 banger is LOUD with no muffler. When i had my 85 with a 2.3 i put a cherry bomb on it and it sounded like a damn circle track car, could hear it for blocks..lol
91stang308 is offline Submit to Clesto

Submit to Digg Submit to Reddit Submit to Furl Submit to Del.icio.us Submit to Jeqq Submit to Spurl  
Reply With Quote
Old 08-25-2009   #5 (permalink)
A.K.A red89coupe
Real Name: Jayson
 
Beernut's Avatar
 
Join Date: Aug 2006
Location:
back in the big O
Posts: 2,280
iTrader: (3)
Friends: (8)
 
Last Online:
03-07-2018 05:23 PM
Time Spent Online: 1 Week 2 Days 8 Hours 53 Minutes 46 Seconds
My Album's:
Beernut's album
Thanks: 0
Thanked 2 Times in 2 Posts
Re: Sputter

what year is it??

I had a IGN mod go bad on one, it would spit, sputter , low on power, run like crap but kept running... The spark/timing was so far off the converter would glow from all the raw fuel. did plugs,wires,coil packs and finally the IGN module fixed it.. try to get a "used" one as they are expensive for a new one and if it dont do it all the time its hard to have it tested.

I picked one up at the local pick and pull lol
__________________
NEVER do business with Sam Rivera AKA Sam Wilson of Rivera Race Chassis. Paid 2800 to put car together. NO work was done, never gave back my turbo kit. Now I see old adds of my parts being sold on craigslist while car was at his shop.
Beernut is offline Submit to Clesto

Submit to Digg Submit to Reddit Submit to Furl Submit to Del.icio.us Submit to Jeqq Submit to Spurl  
Reply With Quote
Old 08-25-2009   #6 (permalink)
130Stang
Real Name: Mike
 
Loadclr's Avatar
 
Join Date: Mar 2007
Location:
Wichita, KS
Posts: 6,236
iTrader: (1)
Friends: (14)
 

Last Online:
02-17-2014 05:31 PM
Time Spent Online: 3 Weeks 1 Day 3 Hours 56 Minutes 35 Seconds
My Album's:
Loadclr's album
My Garage:
Loadclr's Garage

Thanks: 3
Thanked 13 Times in 13 Posts
Send a message via AIM to Loadclr Send a message via Yahoo to Loadclr
Re: Sputter

It's a 92 hatch with an auto tranny. The engine is a dual plug head motor. We have already put in new plugs, coil packs and ignition module. We have also replace the EGR valve and the fuel filter. Also put in a K&N air filter. It's been Seafoamed once and currently has Zmax in it. Sounds like we need to order the plug wires that we didn't get because they quit making the ones we wanted. Thanks everyone.
Loadclr is offline Submit to Clesto

Submit to Digg Submit to Reddit Submit to Furl Submit to Del.icio.us Submit to Jeqq Submit to Spurl  
Reply With Quote
Reply

  Mustangs Insanity > Mustang Talk > Mustangs > 4 Cylinder NA and Turbo

Bookmarks

Tags
sputter


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 12:09 AM.


Powered by vBLies® Version 3.8.2
Copyright ©2000 - 2023
Insanemustangs is not Affiliated with ford in any way. All Image's are property of insanemustangs.com